re = /^.*?(?=\|)/
str = 'uploads/images/adsense.png|uploads/images/tree-7835_960_720.jpg|uploads/images/way-427984_960_720.jpg|uploads/images/friendship-1081843_960_720.jpg|uploads/images/pinky-swear-329329_960_720.jpg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end