$re = '/.*(?:o|s|x|ch|sh)(?=$)/m';
$str = 'lobster
peach
expert
potato';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);