$re = '/\bERP\b/';
$str = 'qwERPa ERP
ERP myERP
not,ERP, /ERP/ :ERP:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);