$re = '/.*[^\d^+^(^)^\-^\s]+.*(?:\d)|(?:\d)(?=.*[^\d^+^(^)^\-^\s]+.*)|(\d)/m';
$str = '+123 (456) 7-8
123a45a432432
1234 B
a12345
a+123 (456) 7-8
+123 a(456) 7-8
+123 a(456) 7-8a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);