using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((0?[1-9])|(1[0-2]))\/((0?[1-9])|((1|2)[1-9])|(3[0,1]))\/[1,2][0-9][0-9][0-9]$";
string input = @"12/31/2000
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}