#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z]+[\d]+[a-zA-Z]+.*"
Local $sString = "test02a-d.test.example.net" & @CRLF & _
"test02b-d.test.example.net" & @CRLF & _
"test03a.test.example.net" & @CRLF & _
"test03b.test.example.net" & @CRLF & _
"test04-d.test.example.net" & @CRLF & _
"test05.test.example.net"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")