#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(" & @CRLF & _
" \[" & @CRLF & _
" ( " & @CRLF & _
" (?:[^][]+|(?1))*" & @CRLF & _
" )" & @CRLF & _
" \]" & @CRLF & _
")"
Local $sString = "[DATA1[OTHERDATA]RUBBISH]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")