#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]+:[0-9]+(?: P)?(?: K)?(?: \+ [0-9]+:[0-9]+(?: P)?(?: K)?)*)$"
Local $sString = "15:15" & @CRLF & _
"1:0" & @CRLF & _
"1:2 K" & @CRLF & _
"1:3 P" & @CRLF & _
"1:4 P K" & @CRLF & _
"3:4 + 3:2" & @CRLF & _
"34:14 P K + 3:1 P" & @CRLF & _
"15:15 K P + "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")