$re = '/.* (\d+) .*/';
$str = 'this is a 100 test';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);