$re = '/(?=^[A-Za-z0-9]+$)(.)+.*\1.*/m';
$str = 'abc1
abc
abc11
1abc1
aabc1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);