$re = '/[^\/]*?(?<=[^\/])$/';
$str = '5020203010101/FIS/CASH FUND/SBG091241212';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);