package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((ftp|http)s?:\/\/)?[\w-]+(\.[\w-]+)+([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?$
`)
var str = `/asdadsasd/asdsad
https://adasd.com/adasdad/adaa
asdasdas/asdasdasd.ads?Asdasda
asdasdas/asdasdasd.ads
adasdd.rgg/asdasdasdas?dasdasd#asdads.as
http://rrsda.COM/cCCC
asdasdsda.ccc
asdsad/asdsad
/asdasdasdasdasd/asdasd/
../asdasdsad/asdasd/asdsad
./asdasdsad.asdasd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}