$re = '/^(?!.*\.net)[^\nA-Z]+$/m';
$str = 'this is .net
test test 1234 % test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);