$re = '/\B@[^@]\w*(?!.*?\s@)/im';
$str = 'hello hi @why helo @blow but @name
hello hi @why helo @blow but name@name
@blow but not know how to resolve this';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);