#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[\w-]+\/[\w-]+(?:;\s*[\w-]+=[\w-]+)*$"
Local $sString = "text/plain; charset=iso-8859-1; foo=bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")