#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[^\n.!?]*((sorry)\b[^.!?:\n\r]+\b((bad|my|poor) english)|(english[^.!?:\n\r]+)\b(tongue|language))\b[^.!?:\n\r]*(?:[.!?:_*])*"
Local $sString = "About 30,500 instances of "sorry bad english". Once a post has been properly edited, this phrase is just noise, and should be deleted." & @CRLF & _
"" & @CRLF & _
"Some words. sorry for bad english. More text." & @CRLF & _
"" & @CRLF & _
"Sorry about my bad english. More text." & @CRLF & _
"" & @CRLF & _
"I'm sorry my english sucks. More text." & @CRLF & _
"" & @CRLF & _
"Sorry for my bad English . More text." & @CRLF & _
"" & @CRLF & _
"sorry for my bad english, _i explained it with everything i can._ More text." & @CRLF & _
"" & @CRLF & _
"Blah de blah de blah. ***And sorry for my bad english..***" & @CRLF & _
"" & @CRLF & _
"Sorry for my English. More text." & @CRLF & _
"" & @CRLF & _
"Sorry for my english and thanks! More text." & @CRLF & _
"" & @CRLF & _
"I'm sorry for my poor english . More text." & @CRLF & _
"" & @CRLF & _
"And sorry for my english. More text." & @CRLF & _
"" & @CRLF & _
"## WBN" & @CRLF & _
"" & @CRLF & _
"And sorry if my english got a little confusing... " & @CRLF & _
"" & @CRLF & _
"pss: sorry, bad english" & @CRLF & _
"" & @CRLF & _
"sorry, english isn't my main language =/." & @CRLF & _
"" & @CRLF & _
" English isn't my first language," & @CRLF & _
"" & @CRLF & _
"English isn't my native language." & @CRLF & _
"" & @CRLF & _
"English isn't my mother language." & @CRLF & _
"" & @CRLF & _
"As english isn't my mother tongue," & @CRLF & _
"" & @CRLF & _
"I don't know if I made myself clear as english isn't my native language," & @CRLF & _
"" & @CRLF & _
"English isn't my primary language,so " & @CRLF & _
"" & @CRLF & _
"My English isn't mother tongue," & @CRLF & _
"" & @CRLF & _
"I hope u understand me, english isn't my mother tongue." & @CRLF & _
"" & @CRLF & _
"I'm sorry for my grammar or spelling mistakes, " & @CRLF & _
"" & @CRLF & _
"First, sorry if my english isn't that great, this isn't my mother tongue. " & @CRLF & _
"" & @CRLF & _
"Sorry for the bad English, English isn't my mother tongue so I'm trying to make the best of it." & @CRLF & _
"" & @CRLF & _
"Sorry for my bad English, it is not my native tongue " & @CRLF & _
"" & @CRLF & _
"## Leave:" & @CRLF & _
"" & @CRLF & _
"It is a sorry excuse for it." & @CRLF & _
"" & @CRLF & _
"He put some English on the ball." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")