re = /([-a-z0-9]+)(?=[ >:]*\+\+)/im
str = 'eojthebrave++
eojthebrave: ++
eojthebrave ++
eojthebrave:;++
eojthebrave++++++++++
match++
t-bot++
willwh++
willwh++trailingstuff...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end