$re = '/[\d\w]+?(?=\-|$)/';
$str = '02-aaaa-mbd-98-2a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);