package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b-([a-zA-Z0-9]+)`)
var str = `sh0rt-t3rm
--no
yes-this`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}