re = /(?<! [a-z]| [a-z]{2})(?<!\b[a-z]|\b[a-z]{2})\.(?! |\d|\.)/i
str = 'C.J. This is my example text. After this sentence there is no space after dot.What should? I want PHP to add whitespace in that case, but not after sentence where I already have white space or like now 3times dot...Another thing is that it can be written how great is to win 1.000.000 on lottery but I really don\'t want it to be 1. 000. 000 after edititng... Also C.J. must stay C.J. and not C. J.... wow that is hard :)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end