re = /^[A-Z]+?:\/\/[A-Z\d\.-]{2,}\.[A-Z]{2,}:(\d{2,5})?/i
str = 'http://test.example.com:80/dir/subdir/file.html
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end