re = /\w[-\w.+]*@([A-Za-z0-9][-A-Za-z0-9]+\.)+[A-Za-z]{2,14}/mi
str = '842766898@qq.com'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end