re = /\b\S+(?=[ \t]+[A-Z]+\b)/m
str = 'Mister Foo BAR is here
Miss Bar-Barz FOO loves cat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end