$re = '/^\d{8}0[12]\d{2,3}$/m';
$str = '123456780123
123456780232
123456789123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);