import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(param1=\\\"false\\\"|class=\\\"param2\\\"|id=\\\"id\\#([^\\\"]+)\\\")([\\ ]{1,}?)";
final String string = "<a param1=\"false\" class=\"param2\" id=\"id#12\" href=\"#1\">toto</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}