$re = '/^(?!.*?[ \'.-]{2})[A-Za-z0-9 \'.-]{1,30}$/ms';
$str = 'Smithers -Jones
Smithers-Jones
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);