package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^A-Za-z0-9\s]`)
var str = `valid characters
#$@$ asdf (*&^%$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}