#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(90|[0-8]?\d)(\.\d+)?, *-?(180|1[0-7]\d|\d?\d)(\.\d+)?$"
Local $sString = "-23, 25" & @CRLF & _
"24.53525235, 23.45235" & @CRLF & _
"04, -23.234235" & @CRLF & _
"43.91343345, 143" & @CRLF & _
"4, -3" & @CRLF & _
"9.757674732245505, 84.58947867620736" & @CRLF & _
"" & @CRLF & _
"23.234, - 23.4234" & @CRLF & _
"2342.43536, 34.324236" & @CRLF & _
"N23.43345, E32.6457" & @CRLF & _
"99.234, 12.324" & @CRLF & _
"6.325624, 43.34345.345" & @CRLF & _
"0, 1,2" & @CRLF & _
"0.342q0832, 1.2324" & @CRLF & _
"-23, 195" & @CRLF & _
"-23, 275" & @CRLF & _
"-23, 185"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")