$re = '/^(?!00)\d\d$/m';
$str = '01
10
99
00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);