$re = '/^(?=^20)(?=(?:.{5}|.{7}))/';
$str = '12345';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);