$re = '/(#\w+)*/mi';
$str = '#tag1, #tag2, #tag3...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);