import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^/]+(?=\\.[^.]+$)";
final String string = "http://www.demo.com/profiles-forum/linda-blair.php\n"
+ "http://www.demo.com/profiles-forum/linda-blair.txt\n"
+ "http://www.demo.com/profiles-forum/linda-blair.jpeg\n"
+ "http://www.demo.com/profiles-forum/linda_blair.php\n"
+ "http://www.demo.com/profiles-forum/linda.blair.txt\n"
+ "http://www.demo.com/profiles-forum/lindablair.jpeg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}