$re = '/^D([0-9]{2})A([0-9])$/';
$str = 'D10A7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);