re = /\bwf(?:\.\w+)+(?:\(\))?/m
str = 'SELECT (wf.Name,
wf.Status)
SELECT wf.Name, wf.Status
SELECT (wf.Name,
wf.Status())'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end