$re = '/^(\d{3}|\d{5}){8}+$/';
$str = '12397982347923934802349344';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);