package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B@\w+`)
var str = `@one @two and bla@three`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}