re = /^.*[P|p]*(OST|ost)*\.*\s*[O|o|0]*(ffice|FFICE)*\.*\s*[B|b][O|o|0][X|x]\s*(\d.)*/i
str = 'test post asdfasdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end