package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Za-z\.A-Za-z0-9]*)`)
var str = `giusdfs.gio01
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}