package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^A|B$`)
var str = `ABC
CAB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}