# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*noted.*|.*binkie*|.*NotedBinkie*)\s?((wha|wa|wo).+)\s(ur|your)\s(gamertag|gt|gamertg|GT)"
test_str = ("your native language ?\n"
"is your native language ?\n"
"where are you from ?\n"
"where are you from @Aripaneagra ?\n\n"
"whats your gamertag @Aripaneagra ?\n"
"whats your gamertag @andi686 ?\n"
"whats your gamertag @andi686?\n"
"whats your gamertag andi686 ?\n"
"whats your gamertag andi686?\n"
"whats your gamertag @andi ?\n"
"whats your gamertag @andi?\n"
"whats your gamertag andi ?\n"
"whats your gamertag andi?\n\n"
"@notedbinkie9727 whats your gamertag ?\n"
"notedbinkie9727 whats your gamertag ?\n"
"noted whats your gamertag ?\n"
"@noted whats your gamertag ?\n\n"
"@notedbinkie9727 whats your gamertag\n"
"@notedbinkie9727 what's your gamertag\n"
"@notedbinkie9727 whats your gamertg\n"
"@notedbinkie9727 what's your gamertg\n"
"@notedbinkie9727 whats your gt\n"
"@notedbinkie9727 wats ur GT\n"
"@notedbinkie9727 wats ur gt\n"
"@notedbinkie9727 whats ur gt\n\n"
"notedbinkie9727 whats your gamertag\n"
"notedbinkie9727 what's your gamertag\n"
"notedbinkie9727 whats your gamertg\n"
"notedbinkie9727 what's your gamertg\n"
"notedbinkie9727 whats your gt\n"
"notedbinkie9727 wats ur GT\n"
"notedbinkie9727 wats ur gt\n"
"notedbinkie9727 whats ur gt\n\n"
"noted whats your gamertag\n"
"noted what's your gamertag\n"
"noted whats your gamertg\n"
"noted what's your gamertg\n"
"noted whats your gt\n"
"noted wats ur GT\n"
"noted wats ur gt\n"
"noted whats ur gt\n\n"
"binkie whats your gamertag\n"
"binkie what's your gamertag\n"
"binkie whats your gamertg\n"
"binkie what's your gamertg\n"
"binkie whats your gt\n"
"binkie wats ur GT\n"
"binkie wats ur gt\n"
"binki whats ur gt\n\n"
"@noted whats your gamertag\n"
"@noted what's your gamertag\n"
"@noted whats your gamertg\n"
"@noted what's your gamertg\n"
"@noted whats your gt\n"
"@noted wats ur GT\n"
"@noted wats ur gt\n"
"@noted whats ur gt\n\n"
"noted whats ur gta\n"
"binki whats ur gta\n\n"
"wats ur GT noted\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.