import re
regex = re.compile(r"\b(?:(?=.{0,3}?\d)[A-Za-z\d]{4}\s??){3}\b")
test_str = ("?K9X6 6GM6 LM11 // not recognized - but it should be\n"
"!K9X6 6GM6 LM11 // not recognized - but it should be\n"
"K0X6 0GM7 LM12! // not recognized - but it should be\n"
"K1X6 1GM8 LM13@ // not recognized - but it should be\n"
"K2X6 2GM9 LM14? // not recognized - but it should be\n"
"K3X6 3GM0 LM15# // not recognized - but it should be\n"
"K4X6 4GM1 LM16* // not recognized - but it should be\n"
"K5X65GM2LM17\n"
"bla bla bla\n"
"this shouldn't be visible\n"
"spod also shouldn't be visible\n"
"but line below should be!!\n"
"K9X66GM6LM11! (see that \"!\" at the end? Help me with this)\n\n"
"K5X65GM2LM17234324122323 //wrong, text is too long\n"
"A9D24 A12E A59E3 //wrong, text block counts 5 characters!\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")