$re = '/(\d{4})-(\d{2})-(\d{2})/';
$str = '2016-08-22 08:00:00
2016-08-22
2024-12-30';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);