re = /(?<=<)[^>]*(?=>)|(?<={)[^}]*(?=})/im
str = 'first option<option 1/option 2/option 3>second option<option 5/option 6/option 7>selection{aaaaa/bbbbb/ccccc}{eeeeee/fffff/ggggg}other string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end