import re
regex = re.compile(r"[ ](?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)")
test_str = "abc def \" gh i \" jkl \" m n o p \" qrst "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)