package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(a)|(b)|(c))(?(2)x|y)`)
var str = `ax
bx
cx
ay
by
cy
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}