package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`connect data::[^:]+::[^:]+::[^:]+::[^:]+::[^:]+::[^:]+::end`)
var str = `Ohter type of lines...
[TCP]: incomeing data: 91 bytes, data=connect data::10.109.0.200data::10.109.0.86data::wandata::p4data::1400data::800data::end
[TCP]: incomeing data: 91 bytes, data=connect data::10.109.0.201data::10.109.8.86data::landata::p4data::1400data::700data::end
[TCP]: incomeing data: 91 bytes, data=connect data::10.109.0.200data::10.109.58.86data::3gdata::p4data::400data::800data::end
something.. else...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}