$re = '/(?<!\(|^)(?!\)|\d\)|$)/m';
$str = '01(01)121210(01)0001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);