$re = '/(?:\s+)?([A-Z][a-zA-Z-]+),?(?:\s+)?([A-Z][a-zA-Z]+):/m';
$str = 'Meck, Mary: Fri 6/14/2019 5:00 PM -- 10:00 PM CLERKPETRO Flinstone, Fred: Fri 6/14/2019 10:00 AM -- 4:00 PM CLERKPETRO Powers, Kenny: Fri 6/14/2019 10:00 PM -- 11:00 PM
Rhodes, Randy: Sat 6/15/2019 10:15 AM -- 11:30 AM SERVCNTR Sat 6/15/2019 11:30 AM -- 12:45 PM CLICK AND PICK Sat 6/15/2019 12:45 PM -- 2:15 PM SERVCNTR
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);