$re = '/\w+\.\w+$/';
$str = '153 - name_of_file.ext';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);