$re = '/(.*?),(.*?),(.*?),(.*?),(.*?)/';
$str = '1,2,3,4,5';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);